Blackbaud is requiring customers to upgrade to versions of their products that support TLS v.1.1 or higher by March 15, 2018. On that date, Blackbaud will begin disabling the TLS v.1.0 encryption protocol in our solutions, so Blackbaud can complete development and testing prior to the PCI Council’s June 30, 2018 deadline. After March 15, 2018, customers still using TLS v.1.0 will not be able to access some of their Blackbaud solutions.

For locally-installed Financial Edge systems:
Users will need to upgrade to 7.87 patch 21 or higher currently planned for release by the end of November 2017. This version will update the encryption protocol used during login to TLS 1.2.  If TLS 1.0 is disabled in your local environment and the compatible version of Financial Edge is not installed, users will receive an error (Error: Unable to establish database connection) and be unable to log in.

NOTE: Blackbaud Support cannot advise whether TLS 1.0 should be disabled, nor can we assist with installing ODBC drivers, Microsoft updates, or disabling TLS 1.0.

See Upgrade for PCI Compliance for full information, including information on operating systems and browsers.

also see 
How do I prepare to disable TLS 1.0 when using Financial Edge on premise?